Zune HD review – setup and initial impressions

I received my Zune HD last night.  Here are some of my initial impressions:

Very nice like ipod-like packaging, and the device feels pretty good.  Not quite as sharp as a MAC, but definitely quality.  I’ll post my impressions as I use it further.  I’m really looking forward to the HD-Radio, wireless sync and integration into my XBOX 360.

Installation & Setup:

Strangely I could not use the radio feature until I synced it with a computer?  So right out the box you have to do the setup.

It amazes me that Microsoft couldn’t do a better job with the drivers and software. I’m running a Vista 64 bit OS on my workstation.

I connected the zune and it could not find drives.   So I installed the ZUNE software from the zune.com site, still when connecting the player to my USB drive I found it is searching for drivers to no avail.  THEN I disconnect the zune, close the zune software, and try again.  This time, the zune drivers install automatically.  Great. so I open the zune software, “no zune connected”.   I disconnect the USB connector for the zune, and it is successfully installed when I plug the USB in again.  THEN the Zune needs to have a software update downloaded and installed before I can use it.

This PAINFUL process took almost an two hours between reboots, updates, installs, drivers… very painful.  MAC’s iPod is far simpler here for sure.

Hopefully my future experience is not the same.   I’ll keep you posted.

Advertisements